PatientOPS Unavailable

Incident Report for OpenPM - S3

Resolved

Access has been restored.
Posted Feb 20, 2026 - 09:01 EST

Investigating

PatientOPS (POPS) is currently unavailable. Our engineers are working diligently to restore functionality.
Posted Feb 20, 2026 - 08:30 EST
This incident affected: PatientOPS.